Mikipro Staff Working From Home

Major incident Hosting Colocation Virtual Hosting Network Transit HSNS / UFB / xDSL Voice SIP Hosted PBXes Other
2020-03-23 13:53 NZST · 1 month, 2 weeks, 5 days, 5 hours, 37 minutes, 25 seconds

Updates

Resolved

With Alert Level 2 announced, operations will be returning to normal.

May 11, 2020 · 18:31 NZST
Issue

Mikipro Staff Working From Home

Due to the government lock downs, MikiPro staff are working from home.

We will still be available on our normal support numbers and via email & portals, but physical access will be limited to only completely necessary work.

Let us know if there is anything we can assist with during these uncertain times.

March 23, 2020 · 13:56 NZST

← Back