Mikipro Staff Working From Home

Major incident Hosting Colocation Virtual Hosting Network Transit HSNS / UFB / xDSL Voice SIP Hosted PBXes Other
2020-08-13 16:20 NZST · 3 weeks, 2 days, 23 hours, 52 minutes, 49 seconds

Updates

Resolved

With Level 2 restrictions most things should be back to normal.

Just a reminder not to visit our offices if you are feeling unwell.

September 6, 2020 · 16:12 NZST
Monitoring

Mikipro Staff Working From Home

Due to the COVID-19 restrictions, MikiPro staff are working from home.

We will still be available on our normal support numbers and via email & portals, but physical access will be limited to only completely necessary work.

Let us know if there is anything we can assist with.

August 13, 2020 · 16:20 NZST

← Back